Apache HTTP Server 2.2.29 Released

The Apache Software Foundation and the Apache HTTP Server Project are pleased to announce the release of version 2.2.29 of the Apache HTTP Server ("Apache"). (Note that 2.2.28 was not released). This version of Apache is principally a security and bug fix maintenance release, and addresses these specific security defects as well as other fixes;

We consider the Apache HTTP Server 2.4 release to be the best version of Apache available, and encourage users of 2.2 and all prior versions to upgrade. This 2.2 maintenance release is offered for those unable to upgrade at this time. For further details, see:

http://www.apache.org/dist/httpd/Announcement2.4.html

Apache HTTP Server 2.4 and 2.2.29 are available for download from:

http://httpd.apache.org/download.cgi

Please see the CHANGES_2.2 file, linked from the download page, for a full list of changes. A condensed list, CHANGES_2.2.29 includes only those changes introduced since the prior 2.2 release. A summary of all of the security vulnerabilities addressed in this and earlier releases is available:

http://httpd.apache.org/security/vulnerabilities_22.html

This release includes the Apache Portable Runtime (APR) version 1.5.1 and APR Utility Library (APR-util) version 1.5.3, bundled with the tar and zip distributions. The APR libraries libapr and libaprutil (and on Win32, libapriconv version 1.2.1) must all be updated to ensure binary compatibility and address many known security and platform bugs. APR version 1.5 and APR-util version 1.5 represent minor version upgrades from earlier httpd 2.2 source distributions.

This release builds on and extends the Apache 2.0 API and is superceeded by the Apache 2.4 API. Modules written for Apache 2.0 or 2.4 will need to be recompiled in order to run with Apache 2.2, and most will require minimal or no source code changes.

When upgrading or installing this version of Apache, please bear in mind that if you intend to use Apache with one of the threaded MPMs (other than the Prefork MPM), you must ensure that any modules you will be using (and the libraries they depend on) are thread-safe.