Apache > HTTP Server > Documentation > Version 2.0 > Modules

Please note

This document refers to the 2.0 version of Apache httpd, which is no longer maintained. Upgrade, and refer to the current version of httpd instead, documented at:

You may follow this link to go to the current version of this document.

Apache Module mod_proxy_http

Available Languages:  en 

Description:HTTP support module for mod_proxy
Module Identifier:proxy_http_module
Source File:proxy_http.c


This module requires the service of mod_proxy. It provides the features used for proxying HTTP requests. mod_proxy_http supports HTTP/0.9, HTTP/1.0 and HTTP/1.1. It does not provide any caching abilities. If you want to set up a caching proxy, you might want to use the additional service of the mod_cache module.

Thus, in order to get the ability of handling HTTP proxy requests, mod_proxy and mod_proxy_http have to be present in the server.


Do not enable proxying until you have secured your server. Open proxy servers are dangerous both to your network and to the Internet at large.


This module provides no directives.

See also

Available Languages:  en